Server System Requirements (PHP and MySQL)

The minimum requirements to install the Chatstack server software on your web server are PHP 5.3.7+ and MySQL 5.1. Please contact your web hosting company or server administrator to verify that your web hosting or web server has these minimum versions of PHP and MySQL.

  • Windows, Unix Server or Hosting Account
  • PHP 5.3.7 or above with PDO MySQL support - Download
  • MySQL 5.1 or above - Download
  • SSL Certificate (Optional but Highly Recommended, SSL with TLS 1.2 support is required for the iPhone app)
The Chatstack PHP Server Software is required to be installed on your server within the /livehelp directory e.g. or within a sub-domain such as etc.

Windows Application System Requirements

We highly recommend that you install the Chatstack Windows desktop application within your Windows PCs. The system requirements for the Chatstack Windows application are shown below.

  • Windows 10, Windows 8, Windows 7 / Vista
  • Chatstack Server Software (v4.0 or above)
  • .NET Framework 4.5 or above (already included with Windows 8, 8.1 and Windows 10) - Download
  • Internet Connection

Mac OS X App System Requirements

The Chatstack Mac OS X app is available as a separate purchase from within the Mac App Store. The Chatstack Mac app has the following system requirements.

  • Mac OS X 10.8 Mountain Lion or above
  • Chatstack Server Software (v4.1 or above)
  • Internet Connection